安装 OpenRave 0.9 在 Ubuntu 14.04 上

0

Abstract: Doing settings of installation is always a pain. My new class in motion planning requires us to install OpenRave 0.9 on Ubuntu 14.04 but unfortunately, there is no PPA for 0.9 version so that we need to compile it by our hands. I've spent a day to solve the dependencies problem and now share with you to make your life easier. Please contact me if any mistake I make below.


OpenRave 0.9 安装方法

本文的英文版在这里

1. 加入包索引

我们需要添加一些新的源的索引地址,用来安装需要的包。因为这个版本的系统并没有自带。
打开这个文件: sudo gedit /etc/apt/source.list.

把这几行添到最后面:

deb http://ppa.launchpad.net/openrave/testing/ubuntu trusty main
deb-src http://ppa.launchpad.net/openrave/testing/ubuntu trusty main

别忘了之后更新列表 这个很重要!这个很重要!这个很重要! sudo apt-get update .

2. 依赖性安装

下面我们安装一些用得上的好Packages,总值运行着一大片代码然后等着就行.

sudo apt-get install libsoqt4-dev libsoqt-dev-common libopenscenegraph-dev liblapack-dev libpcre++-dev libode-dev libbullet-dev libboost-all-dev libxml2-dev collada-dom2.4-dp*

3.工具

这是一些必要的开发工具:

sudo apt-get install cmake g++ git qt4-dev-tools zlib-bin
sudo apt-get install ipython python-dev python-h5py python-numpy python-scipy python-sympy

4.最费时间的一步:编译。

如果你用虚拟机的话,建议多分配些资源再编译,会快很多。

从GitHub下载最新稳定版的 OpenRave 0.9 version:
git clone --branch latest_stable https://github.com/rdiankov/openrave.git

然后开始编译:

cd openrave
mkdir build
cd build
cmake ..
make
sudo make install

运行软件

最后你可以把OpenRave的地址添加到PythonPath里面,这样你就可以直接调例子运行了:

export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:$(openrave-config --python-dir)/openravepy/_openravepy_
export PYTHONPATH=$PYTHONPATH:$(openrave-config --python-dir)

当然了,你也可以直接去根目录查看OpenRave附带的例子:
/usr/local/lib/python2.7/dist- packages/openravepy/_openravepy_0_9/examples

比如这个:

openrave.py --example graspplanning

Reference: https://scaron.info/teaching/installing-openrave-on-ubuntu-14.04.html


声明:本文章为原创,虽然大部分代码是收集过来的,但是本人按照一定的顺序重新调整和测试并在 Parelles Desktop 上安装成功。引用请注明出处。

你可能感兴趣的

载入中...