关于VSCode更新对于emmet2.0支持的配置更改问题。

帕奇式

vscode version 1.14 版本,更新了emmet2.0支持,配置细节又有了新变化。出处
具体细节配置改为

{
    "emmet.useNewEmmet": true,
    "emmet.includeLanguages": {
        "javascript": "javascriptreact",
        "plaintext": "jade"
    }
}

以下用于emmet支持vue格式文件配置

{
    "emmet.useNewEmmet": true,
    "emmet.includeLanguages": {
        "vue-html": "html",
        "vue": "html"
    }
}

需要注意一点,在使用时如输入div*3+tab这类操作不成功时,需要使用触发建议(ctrl+space)功能选择使用。
windows用户的触发建议(ctrl+space)功能存在按键冲突请自行修改。

vscode的emmet支持还在更新当中,部分设置还在变化当中,vetur的作者也在关注此问题并持续改进vetur,还是挺期待vscode后续的变化:),想了解更多问题可以关注一下vetur的跟进工作

vscode version 1.15 版本,对emmet又做出了改进。

现在Emmet缩写显示在建议/自动完成列表中,VS代码默认情况下不再使用Tab键触发Emmet缩写。这解决了两个主要问题:

  1. 当用户想要使用Tab键添加缩进时,发生意外的Emmet展开。

  2. 当用户实际想要扩展Emmet缩写时,建议列表中的项目被插入。

您仍然可以将任何键盘快捷键(Tab键除外)绑定到editor.emmet.action.expandAbbreviation命令或使用Emmet:从命令选项板中展开缩写。

注意:要继续使用Tab键扩展Emmet缩写和片段,请将emmet.triggerExpansionOnTab设置为true。

所以最终想要使用emmit的设置如下:

{
    "emmet.triggerExpansionOnTab": true,
    "emmet.useNewEmmet": true,
    "emmet.includeLanguages": {
        "javascript": "javascriptreact",
        "plaintext": "jade"
    }
}
阅读 7.4k

设计和管理是毕生的课题👨‍💻

867 声望
68 粉丝
0 条评论

设计和管理是毕生的课题👨‍💻

867 声望
68 粉丝
文章目录
宣传栏