3

ng-zorro-antd 受限于 #10430 一直都未发布 Angular6 版本,虽然早已经准备好 #1404

这里的原因是多重的,antd 的 less 版本需要 JavaScript 的支持,想当初我有想把它转成 Scss 版本,看到这些我内心是奔溃的。

而 Less 3.x 认为支持 JavaScript 是诡异的,因此提供了一个叫 @plugin 看起来更没那么诡异来解决 less 调用 JavaScript。

这就像三角恋一样,antd 那边没空重构,Angular Cli 默认又是依赖 less 3.x,虽然这个三角恋只差一行代码而已 #866

zorro 支持 Angular6 吗?

zorro 从第一版本开始就以 APF 格式打包,Angular6 最大的改进是来自底层,而非应用层面,因此就应用层面而言不需要更改任何代码。

唯一你需要改动的便是 rxjs6 的破坏性变更 MIGRATION

怎么做?

综合上述,让 zorro 支持 Angular6 有两种方式,毕竟在三角恋还未理清之前,我们什么事也做不了。

就应用层面而言,其核心在于 antd less 的编译以及 rxjs6 的变更。对于后者因为 zorro 内部大量使用 rxjs5 的类库,在 zorro 未提供 Angular6 版本之前安装 rxjs-compat 是我们唯一的选择。

npm i --save rxjs-compat

而对于前者有两种方案可以解决,这也是本文的核心。

降级 Less

Less 2.7.3 版本是 Angular5 所依赖,并且默认是支持 JavaScript,因此只需要降级 Less 版本就可以正常的使用。

npm i --save less@~2.7.0
对于 yarn 可能会失败,因为 Angular Cli 依赖 less 3,然而虽然依然可以使用 yarn add less@~2.7.0 -E 但好像并不生效,我对 yarn 并不熟悉,希望有人指点这其中的原因。

失去定制主题

前面一直说终究根源在于 Less 3 对 JavaScript 的支持导致的,好在 ng-zorro-antd 在 0.7.1 时新增了 CSS 版本的样式,它是一个已经编译过了 antd 所有样式文件。

当定制主题不是刚需时,可以直接在 angular.json 中引入 antd 的 css 文件,来解决 zorro 样式加载的问题。

"styles": [
  "node_modules/ng-zorro-antd/src/ng-zorro-antd.css",
  "src/styles.less"
]

风险

zorro 0.7.x 已经承诺至 1.0 不会再有破坏性变更,其中 1.0 也标志者 Angular6 的完全支持。

因此,届时你完全可以恢复定制主题功能以及移除 rxjs-compat 亦可。

当然,若你的项目有第三方组件还未提供 Angular6 版本的话,那么这个升级就要先做好调研了,免得蛋疼。


如果觉得我的文章对你有用,请随意赞赏
码农 · 5月29日

@plugin 调用javascript 怎么用

回复

dreius · 6月5日

两个方法都不行啊,公司要用ng-alain,现在在看ng-zorro,用的是angular6.0,按照官方文档做打开后是Cannot GET /

回复

lennon_ke · 6月9日

yarn的改了yarn.lock 里面@angular-devkit/build-angular的less 依赖2.7.3 然后在yarn add @angular-devkit/build-angular 就行了- - 不过好麻烦

回复

蝎男 · 6月13日

angularCli 1.7.4 angular5.2.11, 安装官网起步教程一步一步来,记过报错了
platform.es5.js:79 Uncaught TypeError: Object(...) is not a function

at eval (platform.es5.js:79)
at eval (platform.es5.js:81)
at Object../node_modules/@angular/cdk/esm5/platform.es5.js (vendor.bundle.js:63)
at __webpack_require__ (inline.bundle.js:55)
at eval (scrolling.es5.js:11)
at Object../node_modules/@angular/cdk/esm5/scrolling.es5.js (vendor.bundle.js:79)
at __webpack_require__ (inline.bundle.js:55)
at eval (overlay.es5.js:34)
at Object../node_modules/@angular/cdk/esm5/overlay.es5.js (vendor.bundle.js:55)
at __webpack_require__ (inline.bundle.js:55)

client:153 ./node_modules/@angular/cdk/esm5/observers.es5.js
164:149-155 "export 'inject' was not found in '@angular/core'
@ ./node_modules/@angular/cdk/esm5/observers.es5.js
@ ./node_modules/ng-zorro-antd/esm5/antd.js
@ ./src/app/app.module.ts
@ ./src/main.ts
@ multi (webpack)-dev-server/client?http://0.0.0.0:0 ./src/main.ts

搞不定啊

回复

蝎男 · 6月13日

@dreius 请问你搞定没,也刚用上ng-zorro的,因为项目要用angular5,所以zorro用的0.7,但是一直报错 :(

回复

载入中...