如何通过Java代码判断当前的环境是否支持JRE 9

JDK9已经出来有一段时间了,因此很多流行的Java应用纷纷增添了对JDK9乃至JDK10的支持,比如Tomcat。

我们通过这个链接下载最新的Tomcat源文件包,总共7MB:

https://tomcat.apache.org/dow...

解压之后,在文件夹apache-tomcat-9.0.10-srcjavaorgapachecatalinacore里找到文件JreMemoryLeakPreventionListener.java:

可以看到大量调用工具类JreCompat检测JRE9是否可用:

JreCompat.isJre9Available()

查看isJre9Available的具体实现:

public static boolean isJre9Available() {

     return jre9Available;

}

被一个boolean控制:jre9Available。

jre9Available这个boolean被Jre9Compat.isSupported()控制:

static {

// This is Tomcat 9 with a minimum Java version of Java 8.

// Look for the highest supported JVM first

if (Jre9Compat.isSupported()) {

       instance = new Jre9Compat();

       jre9Available = true;

} else {

     instance = new JreCompat();

     jre9Available = false;

}

}

再看Jre9Compat.isSupported()的代码:

static boolean isSupported() {

       return inaccessibleObjectExceptionClazz != null;

}

如何通过Java代码判断当前的环境是否支持JRE 9

一旦inaccessibleObjectExceptionClazz不为null,说明JRE9可用。

inaccessibleObjectExceptionClazz来自Class.forName("java.lang.reflect.InaccessibleObjectException"),

java.lang.reflect.InaccessibleObjectException这个类正是Java 9引入的。因此如果用Class loader加载不到这个类,一定说明当前的运行环境是Java 9以下。

通过这种方式进行Java运行环境的检测比System.getProperty准确,因为后者获取的信息理论上有可能被别人用setProperty覆盖。

ABAP

通过表CVERS查看Software component的版本信息:

要获取更多Jerry的原创技术文章,请关注公众号"汪子熙"或者扫描下面二维码:

阅读 475发布于 2018-10-26
推荐阅读

SAP成都研究院开发专家,SAP社区导师,SAP中国技术大使

26 人关注
754 篇文章
专栏主页
目录