composer安装和使用

0

下载composer

安装前请务必确保已经正确安装了 PHP。打开命令行窗口并执行 php -v 查看是否正确输出版本号。
打开命令行并依次执行下列命令安装最新版本的 Composer:

php -r "copy('https://install.phpcomposer.com/installer', 'composer-setup.php');"

php composer-setup.php

php -r "unlink('composer-setup.php');"

执行第一条命令下载下来的 composer-setup.php 脚本将简单地检测 php.ini 中的参数设置,如果某些参数未正确设置则会给出警告;然后下载最新版本的 composer.phar 文件到当前目录。

上述 3 条命令的作用依次是:

--下载安装脚本 - composer-setup.php - 到当前目录。

--执行安装过程。

--删除安装脚本。

设置系统环境变量:

使用中国镜像:

(推荐)修改全局配置文件:cmd 输入

composer config -g repo.packagist composer https://packagist.phpcomposer.com

下载完成后 进行安装

(推荐)全局安装

默认下载路径是:C:/ProgramData/ComposerSetup

全局安装是将 Composer 安装到系统环境变量 PATH 所包含的路径下面,然后就能够在命令行窗口中直接执行 composer 命令了。

Mac 或 Linux 系统:

打开命令行窗口并执行如下命令将前面下载的 composer.phar 文件移动到 /usr/local/bin/ 目录下面:

sudo mv composer.phar /usr/local/bin/composer

Windows 系统:

--将 composer.phar 复制到 PHP 的安装目录下面,也就是和 php.exe 在同一级目录。

--在 PHP 安装目录下新建一个 composer.bat 文件,并将下列代码保存到此文件中。

@php "%~dp0composer.phar" %*

最后重新打开一个命令行窗口试一试执行 composer --version 看看是否正确输出版本号。

下载其他依赖工具就在cmd 下先进入所需要工具的项目里面,输入composer require xxxxxxxx 或者修改项目的composer.json文件

你可能感兴趣的

载入中...