Rancher 2.2.5发布,CVE修复,支持K8S 1.15

2019年7月16日,Rancher Labs发布了Rancher全新版本2.2.5,该版本修复了近期发现的安全漏洞CVE-2019-13209,正式支持Kubernetes 1.14,对最新的Kubernetes 1.15也提供了实验性支持,除此之外还带来了一系列功能与优化。

目前,Rancher的Latest和Stable版本信息如下:

CVE修复:CVE-2019-13209

Rancher 2.2.5修复了新近被发现的安全漏洞CVE-2019-13209。该问题最初是由Workiva的Matt Belisle和Alex Stevenson发现并报告,受影响的Rancher版本包括v2.0.0-v2.0.15、v2.1.0-v2.1.10、v2.2.0-v2.2.4。Rancher v1.6不受影响。

该漏洞称为“跨站点Websocket劫持攻击”。攻击者可以通过被攻击者的角色/权限来访问由Rancher管理的集群。它要求被攻击者登录到Rancher服务器,然后访问由开发者托管的第三方站点。一旦完成,开发人员就能够利用被攻击者的权限和身份对Kubernetes API执行命令。更多详情介绍可查看:

https://cve.mitre.org/cgi-bin...

在Rancher 2.2.5发布同期,Rancher Labs官方还发布了Rancher v2.1.11和v2.0.16,这两个版本也提供了此漏洞的修复程序,可供尚未升级至Rancher 2.2.x的用户使用。

功能与优化

  • 正式支持Kubernetes 1.14版本
  • 添加对Kubernetes 1.15版本的实验性支持
  • 在Kubernetes 1.14及以上版本的集群中,支持CoreDNS作为默认的dns提供程序
  • 在UI中为Rancher配置的集群公开证书过期信息,并且在证书过期前30天起发出告警
  • 对于使用Rancher直接配置集群,支持在快照配置中自定义CA,从而S3快照服务将可信任内部签名的证书
  • 为EKS集群添加了对Kubernetes v1.13的支持

Bug修复

以下是这一版本主要修复的bug。您可参考Rancher的milestone获取完整的列表:

https://github.com/rancher/ra...

  • 修复了升级到Rancher v2.2.4项目成员未在用户界面显示的问题 [20825]
  • 修复了节点驱动程序计算机配置可能会因“运行SSH命令出错”错误而导致失败的问题 [20753]
  • 修复了Minio配置为备份目标时Etcd快照超时的问题 [19496]
  • 修复了在rancher-server容器中设置HTTP_PROXY和HTTPS_PROXY环境变量以允许其接触公共网络时,不能使用Rancher节点驱动功能配置节点的问题 [20709]
  • 修复了删除etcd成员时可能导致Rancher配置的集群中etcd损坏的问题 [19696]
  • 修复了在应用程序更新过程中helm超时的问题 [20289]
  • 修复了在配置了etcd快照的设置中Rancher sever每5分钟崩溃一次的问题 [20964]
  • 修复了若Catalog内的程序有错误应答、且该应答被保存后,用户无法修复Catalog应用程序的问题 [21027]
  • 修复了Rancher配置集群的Azure Cloud配置有Service Principal时多个订阅无法运行的问题 [21124]
  • 修复了普通用户无法列出多集群的应用程序修订版的问题 [20919]
  • 修复了告警未遵守http_proxy参数的问题 [20926]

若您想了解与上述各个issue相关的详细信息,请至Rancher GitHub issue界面输入issue编号进行查询:

https://github.com/rancher/ra...

下载及升级

您可以至Rancher GitHub主页阅读完整的Rancher 2.2.5 Release Note、下载使用最新版本、或了解更多与升级回滚有关的注意事项。

GitHub链接:

https://github.com/rancher/ra...

阅读 273发布于 7月17日
推荐阅读
Rancher
用户专栏

Docker、Kubernetes与容器云相关技术干货,容器编排与调度、微服务架构、CI/CD、各类部署实战和代码级干...

864 人关注
303 篇文章
专栏主页
目录