Sass 安装

 阅读约 3 分钟

Sass的系统需求

  • 操作系统 - Sass是独立于平台的
  • 浏览器支持 - Sass在Edge/IE(来自IE 8)、Frefox、Chrome、Safari、Opera中工作
  • 编程语言 - Sass基于Ruby

Sass官方网站:https://sass-lang.com/

安装Sass

当我们在命令行上安装Sass时,我们需要将能够运行的Sass可执行文件来将 .sass 和 .scss 文件编译为 .css 文件:

sass source/stylesheets/index.scss build/stylesheets/index.css

首先使用下面的选项之一安装sass,然后运行sass-version以确保安装正确。如果是,这将包括1.22.12,我们还可以运行SASS——帮助了解命令行接口的更多信息。

  • 随处安装(独立)
    我们可以通过从GITHUB下载操作系统的包并将其添加到您的路径上,在Windows、MAC或Linux上安装SAS。所有这些都没有外部依赖项,也不需要安装其他任何东西。
  • 随处安装(NPM)
    如果我们使用的话,可以通过运行新版本来安装:

    npm install -g sass

    但是,请注意,这将安装sass的纯 JavaScript 实现,它的运行速度比这里列出的其他选项稍慢。但是它有相同的接口,所以如果我们需要更高的速度,以后在另一个实现中交换会很容易。

  • 安装在Windows上(Chocolatey)

    如果使用适用于Windows 的Chocolatey软件包管理器,则可以通过运行安装Dart Sass:

    choco install sass
  • 在Mac OS X上安装(Homebrew)

    如果使用Mac OS X的自制软件包管理器,则可以通过运行安装Dart Sass:

    brew install sass/sass/sass

使用

Sass 可以有三种方式使用:

  • 作为命令行工具
  • 作为独立的 Ruby 模板
  • 作为 Rack-enabled 框架的插件

无论使用哪一种都需要先安装 Sass gem:

gem install sass

在命令行中运行Sass:

sass input.scss output.css

监视单个 Sass 文件,每次修改并保存时自动编译:

sass --watch input.scss:output.css

监视整个文件夹:

sass --watch app/sass:public/stylesheets

更多命令的用法请通过 sass --help 获取帮助。

在 Ruby 中使用 Sass 也非常容易,Sass gem 安装完毕后运行 require "sass" 然后按照下面的方法使用 Sass::Engine:

engine = Sass::Engine.new("#main {background-color: #0000ff}", :syntax => :scss)
engine.render #=> "#main { background-color: #0000ff; }\n"
阅读 83发布于 2019-11-19

推荐阅读
目录