electron踩坑之remote of undefined

electron更新后使用remote模块踩坑

之前的项目,引用electron的remote可以直接调用electron.remote来去使用,而近期使用electron却频繁报错???踩坑后我快速去查看了下官方文档,是不是electron进行了更新?果然不出所料,在electron 10中,修改了enableRemoteModule默认为false,我们需要手动将其修改为true。

 此前版本中我们使用electron中的remote模块时,不需在主进程的窗口中加入enableRemoteModule:true参数才能够调用remote模块,而在electron 10中,我们需要加入该参数才能调用该模块。

//引入electron
let electron = require('electron')
//引入remote模块
let remote = electron.remote
//打印remote模块
console.log(remote)

 在未加入参数前,会引起报错。
在这里插入图片描述
 而在主进程中我们需要向webPreferences配置参数enableRemoteModule:true来打开remote模块,使得渲染进程中可以调用主进程的方法,我们需要对mianWindow来配置:

 mainWindow = new BrowserWindow({
        width:600,
        height:800,
        /* 启用Node继承 */
        webPreferences:{
            nodeIntegration:true,
            enableRemoteModule:true
        }
    })

 
问题解决,踩坑完毕。

阅读 177

推荐阅读