confluence宏插件开发01-搭建开发环境

竣峰

最近在研究Confluence宏的开发,记录和整理一下开发过程中遇到的问题。

前提说明

  1. 你需要掌握基本的java知识。Conflunce是用Java开发的wiki, 所以如果你想开发Confluence插件,基本的java语法还是要掌握的

Windows安装

步骤一,检查JAVA_HOME环境变量

  1. 如果你还没安装jdk,需要先安装JDK 1.8或更新的版本。如果你已经安装好了jdk,并且配置好了JAVA_HOME,请直接到步骤二
  2. 依次打开 win10 开始菜单》windows系统》控制面板》系统和安全 》系统》高级系统设置》环境变量
  3. 添加系统变量JAVA_HOME,对应的值是你的JDK安装的目录,比如:C:\Program Files\Java\jdk1.8.0

步骤二,下载及安装SDK

  1. 下载最新版本的SDK
  2. 双击打开下载好的SDK安装文件
  3. 跟随安装界面一步步安装

步骤三,检查安装结果

打开windows的命令行工具。输入以下命令

atlas-version

如果安装成功,你会看到类似以下的返回结果:

ATLAS Version:    8.2.6
ATLAS Home:       C:\Applications\Atlassian\atlassian-plugin-sdk-8.2.6
ATLAS Scripts:    C:\Applications\Atlassian\atlassian-plugin-sdk-8.2.6\bin
ATLAS Maven Home: C:\Applications\Atlassian\atlassian-plugin-sdk-8.2.6\apache-maven-3.5.4
AMPS Version:     8.1.0
--------
Executing: "C:\Applications\Atlassian\atlassian-plugin-sdk-8.2.6\apache-maven-3.5.4\bin\mvn.cmd" --version -gs C:\Applications\Atlassian\atlassian-plugin-sdk-8.2.6\apache-maven-3.5.4/conf/settings.xml
Apache Maven 3.5.4 (1edded0938998edf8bf061f1ceb3cfdeccf443fe; 2018-06-18T02:33:14+08:00)
Maven home: C:\Applications\Atlassian\atlassian-plugin-sdk-8.2.6\apache-maven-3.5.4\bin\..
Java version: 1.8.0_91, vendor: Oracle Corporation, runtime: C:\Program Files\Java\jdk1.8.0\jre
Default locale: zh_CN, platform encoding: GBK
OS name: "windows 10", version: "10.0", arch: "amd64", family: "windows"

参考资料

https://developer.atlassian.c...

阅读 108
34 声望
0 粉丝
0 条评论
你知道吗?

34 声望
0 粉丝
宣传栏