不满足在启用Hyper-V 或DeviceCredential Guard的情况下运行VMware player的最低要求

JerryWang_汪子熙

我在Windows10安装VMWare workstation 15 Player,版本信息如下:

在试图启动虚拟机时,遇到如下错误消息:

您的主机不满足在启用Hyper-V 或Device/Credential Guard的情况下运行VMware player的最低要求。

我的Windows10版本号为:version 1909,OS Build 18363.1316

对于我这个Windows10版本,如果想使用VMWare workstation player 15.5.5,VMWare官网给出的解决方案是:在windows宿主机里禁掉Hyper-V,同时禁掉Virtualization-based Security(简称VBS):

Disable Hyper-V in the Windows host, then launch VMware Workstation and power on VMs. Note that Windows host VBS will be disabled automatically if Hyper-V is disabled

If using Windows 10 1909 or earlier, the system requirements are not met and therefore Virtualization Based Security has to be set as "Not Enabled".

在Turn windows features on or off里,将Hyper-V相关的选项前的checkbox全部取消:

执行命令行:

bcdedit /set hypervisorlaunchtype off:

确保运行成功:

运行services.msc:

确保和Hyper V相关的服务,只有下列服务处于running状态:

  • Hyper-V Host Compute Service
  • Hyper-V Virtual Machine Management

将Hv Host service这些服务关闭:

然后使用我CSDN上的这个powershell脚本:

在管理员(Administrator)模式下,运行powershell脚本:

./DG_Readiness_Tool_v3.6.ps1 -Ready:

显示Credential-Guard is enabled and running:

运行下列脚本禁掉Credential-Guard:

./DG_Readiness_Tool_v3.6.ps1 -Disable

显示绿色的Disabling Hyper-V and IOMMU successful, 说明脚本执行成功了。

至于脚本报的红色错误消息:

del : Cannot find path 'C:\Windows\System32\CodeIntegrity\SIPolicy.p7b' because it does not exist.

可以忽略它。这个错误消息参考这个Github issue.

最后运行命令msinfo32:

Virtualization-based security应该处于not running状态:

之后虚拟机即可顺利启动:

更多Jerry的原创文章,尽在:"汪子熙":

阅读 206

Jerry Wang的SAP技术专栏
SAP成都研究院开发专家,SAP社区导师,SAP中国技术大使

Jerry 2007年从电子科技大学计算机专业硕士毕业后进入SAP成都研究院工作至今, SAP社区导师,SAP中国技术大使。

632 声望
90 粉丝
0 条评论
你知道吗?

Jerry 2007年从电子科技大学计算机专业硕士毕业后进入SAP成都研究院工作至今, SAP社区导师,SAP中国技术大使。

632 声望
90 粉丝
宣传栏