老项目更新skynet版本

Mark
今天逛了下云风的博客,发现skynet已经发布到1.5.0了,之前的老项目一直用skynet1.1.0,看到最近做了那么多修改,所以心血来潮,更新老项目的skynet版本。
想法是好的,实现起来过程颇为周折。首先是老版本只支持到lua5.3,现在需要换新的lua5.4.3,有最新的5.4.4版本,但是skynet貌似还没切换到最近的,当前有一个分支是支持的5.4.4版本的,云风还没合入主线,基于项目稳定着想,保险一点我先把lua从5.3更新到5.4.3版本了。
然后,就是g++升级的问题。这个还好解决cenos7只需要执行下面几个命令就更切换到8.3版本了,centos7自带的4.3版本实在是没法看。g++升级命令如下
sudo yum install centos-release-scl
sudo yum install devtoolset-8-gcc*
scl enable devtoolset-8 bash
source /opt/rh/devtoolset-8/enable
还有一个问题就是之前老项目用到了lua_newuserdata新版的需要lua_newuserdatanv 取代,这部分修改最恶心了,要整个项目搜一遍=。=。没啥技术含量,都是体力活。
阅读 459

思绪来的快去的也快,就在这里留下点什么吧。

1 声望
1 粉丝
0 条评论

思绪来的快去的也快,就在这里留下点什么吧。

1 声望
1 粉丝
文章目录
宣传栏