升级到Xcode 4.5提示: “does not have access to iOS 5.1 simulator”

是不是免费用户升级到4.5就没法安装5.1的模拟器了,一安装就提示"does not have access to iOS 5.1 simulator"
有没有同学最近遇到跟我一样的问题?!

阅读 4.5k
评论 2012-09-23 提问
    3 个回答

    哥不做iOS开发,通过强大滴搜索引擎找到了一些方案~ 供参考

    1. 网上讨论的一种解决方案是,进入苹果开发者中心,你会发现警告提示,在提示后有一个小蓝色的文字链接,点击进入新的许可协议,然后选择接受就好。 但是有些人反馈这种方法不是所有人都能成功,得看人品 -,-
    2. 去苹果开发者下载中心下载4.4.1的版本的Xcode安装,然后右击Xcode.app显示包内容,然后找到Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs 将拷贝iPhoneSimulator5.1.sdk到这个位置。 重启下应用看看是不是大功告成了?!

    当然我建议花99刀成为付费用户那就一劳永逸了嘛~

    评论 赞赏 2012-09-23

      Xcode本来就是免费的,应该和免费无关。我刚升级到正式版后也无法连接设备调试了,报和楼主同样的错误。同时iOS6和MAC10.8的文档也无法打开。所以还是用回4.5GM了。。。

      评论 赞赏 2012-09-23

        我感觉每次XCode发新版本都会有这样的问题。过1天半天就解决了。apple的天才们没有吧资源放在服务器上。
        上次4.4刚刚发布也是,不能装command line tools。过了半天就好了。

        评论 赞赏 2012-09-24
          撰写回答

          登录后参与交流、获取后续更新提醒