jQuery哪个版本支持手机浏览器

boxiZen
  • 77

RT,jQuery从哪个版本开始支持手机浏览器?

评论
阅读 19.1k
4 个回答
✓ 已被采纳

更新:补充一个《自己编译jQuery的教程》。


如果一个页面只对应手机端的话,用jQuery 2.x比jQuery 1.x好,因为没有对IE低版本的额外支持。同时,你还可以选择取消掉一些项目需求里不包含的内容,来编译出来你自己需要的版本,以此压缩jQuery的大小。见《自己编译jQuery

兼容性直接看这里吧:http://jquery.com/browser-support/

如果是要做响应式的话,为了全浏览器兼容,只有用jQuery 1.x的最新版了。


P.S.我不知道jQuery有多惯坏初学者……

jQuery的方法 原生方法/方案 移动端兼容性
$("") queryselectorall all
addClass/removeClass classList.add/classList.remove some
on/bind/live事件绑定 addEvent all
dom ready script放在DOM底部 all
attr getAttribute/setAttribute all
css style all
html innerHTML all
text textContent all
animate CSS3 transition/animation most
each forEach all

你可能需要的一些工具方法,比如jQuery.type,都可以到jQuery源码里扒,移动端一寸流量一寸金,为何需要这么大,这么笨重的库?

P.S.2.相比起来,我觉得zepto更适合移动端。

移动端更合适用zepto

使用Zepto吧,短小精悍,采用模块开发,封装自己常用的模块。
http://zeptojs.com/

移动端不要用jq~~

logo
101 新手上路
合作问答

面向新手开发者的问题集中营

宣传栏