tornado使用websocket问题

test1001
  • 4
新手上路,请多包涵

tornado里面使用websocket的时候浏览器显示Can "Upgrade" only to "WebSocket".将Chromium和Firefox升级到最新版本以后还是不能解决

回复
阅读 4.1k
2 个回答

那是因为你直接用http协议访问的。
websocket客户端要用要用ws://

var wsUpdater = {
    socket: null,
    start: function(){
        if ("WebSocket" in window) {
            wsUpdater.socket = new WebSocket("ws://xx/websocket");
        } 
        else {
            wsUpdater.socket = new MozWebSocket("ws://xx/websocket");
        }
        wsUpdater.socket.onmessage = function(event) {
            document.write(event.data)
        };
    }
};
wsUpdater.start();

一个简单的例子。
参考文档。http://qinxuye.me/article/ways-to-continual-sync-browser-and-server/

宣传栏