Android Studio碰到一个奇葩问题finished with non-zero exit value 2

caoxiangyu
  • 17

Error:Execution failed for task 'appdexDebug'.

com.android.ide.common.process.ProcessException: org.gradle.process.internal.ExecException: Process 'command 'C:\Program Files\Java\jdk1.8.0_31\bin\java.exe'' finished with non-zero exit value 2

项目运行的时候会报这个异常,在网上查了很多资料,说是调用的包有重复报名或者是重复调用jar包
dependencies {

compile 'com.android.support:appcompat-v7:22.2.0'
compile 'com.android.support:support-v4:22.2.0'
compile 'com.loopj.android:android-async-http:1.4.8'
compile 'com.nostra13.universalimageloader:universal-image-loader:1.9.4'

}
这是我调用的第三方包,实在没看出有什么异常,也不存在重复jar包的情况
更奇葩的是,我把gradle的版本号从1.3.0替换成1.2.3就可以运行几次成功,然后又不行了,然后我再换成1.3.0就又可以运行几次。。。实在是不知道怎么办了,求大神帮忙解决

我的app gradle文件
apply plugin: 'com.android.application'

android {

compileSdkVersion 22
buildToolsVersion "22.0.1"

defaultConfig {
    applicationId "com.example.fangmitao.fangmitao"
    minSdkVersion 15
    targetSdkVersion 21
    versionCode 1
    versionName "1.0"
}
buildTypes {
    release {
        minifyEnabled false
        proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
    }
}

}

dependencies {

compile 'com.android.support:appcompat-v7:22.2.0'
compile 'com.android.support:support-v4:22.2.0'
compile 'com.loopj.android:android-async-http:1.4.8'
compile 'com.nostra13.universalimageloader:universal-image-loader:1.9.4'

}

我的project文件
// Top-level build file where you can add configuration options common to all sub-projects/modules.

buildscript {

repositories {
    jcenter()
}
dependencies {
    classpath 'com.android.tools.build:gradle:1.3.0'

    // NOTE: Do not place your application dependencies here; they belong
    // in the individual module build.gradle files
}

}

allprojects {

repositories {
    jcenter()
}

}

回复
阅读 48.8k
10 个回答
✓ 已被采纳

遇到过,忘记怎么解决了。。。clear,rebuild,或重启试下。。

您好 请问最后您的问题怎么解决的 QQ1055478864 求解

有可能是代码错误导致无法编译,仔细检查一下。rebuild解决问题概率很小

335210622
  • 3
新手上路,请多包涵

麻烦问下 这个问题解决了吗 ? 本人也正在被这个问题困扰呢

饭屋饭屋11
  • 1
新手上路,请多包涵

原因不太清楚,我向drawable中粘贴了一张.9图就出现这个了

豆小豆33
  • 1
新手上路,请多包涵

你把targetSdkVersion 改成22就可以了

grnwich
  • 1
新手上路,请多包涵

好像As不支持JDK1.8导致的

这个错误在app的build.gradle里面添加下面这句就好了

android { 
    defaultConfig { 
        multiDexEnabled true
    }
}
宣传栏