Android stuido 中 java 1.8 Lambda

xcc3641
  • 76

图片描述

自己本机java版本确实是1.8的,而且环境配置没有问题,为什么android studio里会显示
图片描述

这里也是配置好了的~
图片描述
有人知道这个问题吗?

回复
阅读 3.9k
2 个回答
Bpazy
  • 481
✓ 已被采纳

Android 不支持 Java 8 编译,最广泛的支持是Java 6的,Java 7的部分特性也可以得到适配,Java 8就别想了……

另外,新版AS的语言环境会和编译环境绑定,修改可以在Gradle中进行
如 编译使用 Java 6 可以这么配置

compileOptions {
    sourceCompatibility JavaVersion.VERSION_1_6
    targetCompatibility JavaVersion.VERSION_1_6
}
撰写回答
你尚未登录,登录后可以
  • 和开发者交流问题的细节
  • 关注并接收问题和回答的更新提醒
  • 参与内容的编辑和改进,让解决方法与时俱进
宣传栏