使用n升级到node.js 5.5.0,可是运行node -v 查看版本还是 v0.10.38

王道中强流
  • 1.7k

我的node版本是v0.10.38

# node -v
v0.10.38

我想升级到最新版5.5.0

搜了一下 都说用n来升级node版本。
于是我安装了n

# npm install -g n
/usr/bin/n -> /usr/lib/node_modules/n/bin/n
n@2.1.0 /usr/lib/node_modules/n

然后运行n 却提示 没有已安装的node版本

# n

  Error: no installed version

  Usage: n [options/env] [COMMAND] [args]

  Environments:
    n [COMMAND] [args]            Uses default env (node)
    n io [COMMAND]                Sets env as io
    n project [COMMAND]           Uses custom env-variables to use non-official sources

  Commands: ...后面的省略...

于是我安装了一个最新版:

# n latest

     install : node-v5.5.0
       mkdir : /usr/local/n/versions/node/5.5.0
       fetch : https://nodejs.org/dist/v5.5.0/node-v5.5.0-linux-x64.tar.gz
######################################################################## 100.0%
   installed : v5.5.0

然而查看node版本依然是0.10.38

# node -v
v0.10.38
回复
阅读 9.6k
5 个回答

node的环境变量有问题吧,可以带上绝对路径试一下

建议安装nvm,能够兼容多个版本, 而且能够随时切换node版本.
搬运工: http://www.tuicool.com/articles/Vzquy2

使用which node看一下你使用的node是不是在n安装的目录下(即/usr/local/n/versions/node/5.5.0)
如果不是的话,需要把n相关的路径加到PATH里面

宣传栏