npm install -g contextify 报错

tablecell
  • 1.5k

npm install -g contextify

npm ERR! node v5.1.1
npm ERR! npm  v3.3.12
npm ERR! code ELIFECYCLE

npm ERR! contextify@0.1.15 install: `node-gyp rebuild`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the contextify@0.1.15 install script 'node-gyp rebuild'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the contextify package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     node-gyp rebuild
npm ERR! You can get their info via:
npm ERR!     npm owner ls contextify
npm ERR! There is likely additional logging output above.

参照 http://stackoverflow.com/questions/27265349/npm-install-failing-in-windows-7
已经安装了vs2012和python2.7

回复
阅读 4.1k
2 个回答

没安装过这个插件。你可以试试更新下node和npm,可能这个插件现在的版本对于node和npm的版本有要求,你本机的node和npm可能达不到它要求的版本。

Contextify
YOU DON'T NEED THIS MODULE ON NODE >= 0.12

As of Node 0.12, Contextify has been merged into Node (thanks to @domenic), replacing the native vm module. The code has been improved on since then, so if at all possible, you should use a newer Node and the native vm module. Note that newer versions of JSDOM no longer depend on Contextify.

The README below applies to Node 0.10 and below.

你知道吗?

宣传栏