ubuntu16.4 下列软件包有未满足的依赖关系: libapache2-mod-php5

正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
 libapache2-mod-php5 : 依赖: libssl1.0.0 (>= 1.0.0) 但是它将不会被安装
                       依赖: apache2-api-20120211
                       依赖: apache2 (>= 2.4) 但是它将不会被安装
                       依赖: php5-common (= 5.5.9+dfsg-1ubuntu4.16) 但是它将不会被安装
                       依赖: ucf 但是它将不会被安装
                       依赖: tzdata 但是它将不会被安装
                       推荐: php5-cli 但是它将不会被安装
 libkf5guiaddons5 : 依赖: libqt5gui5 (>= 5.0.2) 但是它将不会被安装 或
                            libqt5gui5-gles (>= 5.0.2) 但是它将不会被安装
 libkf5prison1 : 依赖: libqt5gui5 (>= 5.3.0) 但是它将不会被安装 或
                         libqt5gui5-gles (>= 5.3.0) 但是它将不会被安装
 libkf5screen-bin : 依赖: libqt5gui5 (>= 5.0.2) 但是它将不会被安装 或
                            libqt5gui5-gles (>= 5.0.2) 但是它将不会被安装
 libkf5screen6 : 依赖: libqt5gui5 (>= 5.0.2) 但是它将不会被安装 或
                         libqt5gui5-gles (>= 5.0.2) 但是它将不会被安装
 libkf5waylandserver5 : 依赖: libqt5gui5 (>= 5.0.2) 但是它将不会被安装 或
                                libqt5gui5-gles (>= 5.0.2) 但是它将不会被安装
 libpango-1.0-0 : 依赖: fontconfig (>= 2.1.91)
 libqmenumodel0 : 依赖: libqt5gui5 (>= 5.0.2) 但是它将不会被安装 或
                          libqt5gui5-gles (>= 5.0.2) 但是它将不会被安装
 libqt5multimedia5 : 依赖: libqt5gui5 (>= 5.2.0) 但是它将不会被安装 或
                             libqt5gui5-gles (>= 5.2.0) 但是它将不会被安装
 libqt5multimediaquick-p5 : 依赖: libqt5gui5 (>= 5.0.2) 但是它将不会被安装 或
                                    libqt5gui5-gles (>= 5.0.2) 但是它将不会被安装
                            依赖: libqt5quick5 (>= 5.4.0) 但是它将不会被安装 或
                                    libqt5quick5-gles (>= 5.4.0) 但是它将不会被安装
 libqt5x11extras5 : 依赖: libqt5gui5 (>= 5.0.2) 但是它将不会被安装 或
                            libqt5gui5-gles (>= 5.0.2) 但是它将不会被安装
 mount : 预依赖: libblkid1 (>= 2.17.2) 但是它将不会被安装
         预依赖: libmount1 (>= 2.25) 但是它将不会被安装
E: 错误,pkgProblemResolver::Resolve 发生故障,这可能是有软件包被要求保持现状的缘故。

我这接下来该怎么做

阅读 15.4k
3 个回答

Ubuntu 16.04默认是PHP7。所以你安装5的版本没有。

···
sudo apt-get update(更新源)
sudo apt-get -f install
···

会自动安装依赖的包

撰写回答
你尚未登录,登录后可以
  • 和开发者交流问题的细节
  • 关注并接收问题和回答的更新提醒
  • 参与内容的编辑和改进,让解决方法与时俱进
宣传栏