gulp 运行出现这个警告,求解!

clipboard.png

DEPRECATION WARNING on line 87 of D:/Program Files/Ruby23-x64/lib/rub
0/gems/compass-core-1.0.3/stylesheets/compass/css3/_deprecated-suppor
 interpolation near operators will be simplified
 version of Sass. To preserve the current behavior, use quotes:

"$moz-"#{$experimental-support-for-mozilla} "$webkit-"#{$experimental
r-webkit} "$opera-"#{$experimental-support-for-opera} "$microsoft-"#{
al-support-for-microsoft} "$khtml-"#{$experimental-support-for-khtml}


 the sass-convert command to automatically fix most cases.


DEPRECATION WARNING on line 92 of D:/Program Files/Ruby23-x64/lib/rub
0/gems/compass-core-1.0.3/stylesheets/compass/css3/_deprecated-suppor
 interpolation near operators will be simplified
 version of Sass. To preserve the current behavior, use quotes:

"$ie6-"#{$legacy-support-for-ie6} "$ie7-"#{$legacy-support-for-ie7} "
gacy-support-for-ie8}')

 the sass-convert command to automatically fix most cases.
阅读 2k
评论 2016-08-01 提问
    3 个回答
    leftstick
    • 26.4k

    我的方法比较土,但权当尝试吧:

    1. 关掉所有cmd窗口,最好杀进程。如果不会,重启电脑

    2. 执行compass clean

    3. 再重试你的命令

    评论 赞赏 2016-08-01

      谢邀, 基本没有使用 windows,所以这个错误没有碰到过,不过看错误,感觉像是 ruby的依赖问题,个人建议,你先确保自己的ruby环境没有问题,因为windows ruby的安装问题多种多样。

      终极大招-- 放弃掉 sass,其实你自己仔细的想一想,你的css 没有必要非要用sass,可以用 less,stylus,或者 postcss来替换,不要人云亦云。。

      评论 赞赏 2016-08-07

        Deprecation Warning 就是提示你有特性将要被弃用啦,找到它提示的行,按它说的改就好了

        不改也不影响,反正是warning,代码工作者从不careㄟ(▔ ,▔)ㄏ

        评论 赞赏 2016-08-07
          撰写回答

          登录后参与交流、获取后续更新提醒