Android Studio 2.2 beta2 更新后强制将 Gradle 版本升级为 2.14.1,有没有遇到同样情况的?

男子汉大豆腐
  • 136

今天早上更新了 Android Studio 2.2 beta2 版本,结果过不了编译了,提示如下图

clipboard.png

点击 Fix 就自动将 gradle 版本改为 2.14.1,Android plugin 改为 2.1.3 了。

我的 gradle 版本原来是 2.10,Android plugin 是 2.1.0,今天更新后就无法使用 Android plugin 是 2.1.0 了,gradle 版本倒是可以换回 2.1.0。

因为项目打包需求,还是希望使用 2.10 和 2.1.0 的配置,有没有遇到同样情况的同学,麻烦给点提示,多谢!

回复
阅读 8.8k
3 个回答
食用淡水鱼
  • 2.2k
✓ 已被采纳

这次版本更新,Studio做了件流氓的事——如果你的gradle目录是在studio目录下,更新后studio会把你的2.10 gradle强制删除,并用2.14.1给你替换,你需要重新下一个配置进去

如果你的gradle目录没有被删,那改下设置里面的gradle目录指向就可以了

Sanchi
  • 361

android studio升级2.1.3之后,莫名其妙就删除了安装目录下的gradle文件夹中的其他gradle版本,强制升级到了gradle-2.14.1,项目中只能使用2.1.3以上的版本。其实要是对gradle版本没有其他特殊要求的话建议使用高一点的版本。如果跟题主一样要编译方面的限制的话,按照如下步骤恢复为原来的版本:

  • 首先查看android studio安装目录下的gradle文件夹,如果你的gradle-2.10文件夹已经被删除,就到http://gradle.android-studio.org/重新下载一个放到该目录。

  • 然后进入settings搜索gradle,修改Gradle home为下载好的gradle-2.10目录。

  • 最后修改项目中gradle/gradle-wrapper.properties文件的distributionUrl属性(如distributionUrl=https\://services.gradle.org/distributions/gradle-2.4-all.zip),以及build.gradle文件中的gradle版本,重新编译,一切OK。

Android Studio gradle plugin 确实是需要与特定版本的Gradle配合使用的,这是正常现象。以前也是一样的,只要按照它的要求来就可以了。

宣传栏