安装不了php5-dev

ECEPA_禧戏
  • 552

本来想安装php-mongodb拓展,需要phpize,又没有。网上说安装php5-dev,结果又出错,怎么办5555
错误:
sudo apt-get install php5-dev
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
php5-dev : 依赖: libssl-dev 但是它将不会被安装

        推荐: pkg-php-tools 但是它将不会被安装

E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。

回复
阅读 4.1k
1 个回答

时隔大半年,我也遇到了同样的错误,不知题主是否已经解决,我自己是花了一个多小时找到了处理方案,这边贴一下处理方案,以免他人遇到同样的问题却找不到答案:
首先,php5-dev扩展无法安装:
sudo apt-get install php5-dev:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
php5-dev : 依赖: libssl-dev 但是它将不会被安装

        推荐: pkg-php-tools 但是它将不会被安装

E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。

那就安装依赖libssl-dev,提示:
sudo apt-get install libssl-dev :
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
libssl-dev : 依赖: libssl1.0.0 (= 1.0.1f-1ubuntu2) 但是 1.0.1f-1ubuntu2.19 正要被安装
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。

原因:已安装的libssl1.0.0版本太高, 无法支持
处理方案:
dpkg -l libssl
期望状态=未知(u)/安装(i)/删除(r)/清除(p)/保持(h)
| 状态=未安装(n)/已安装(i)/仅存配置(c)/仅解压缩(U)/配置失败(F)/不完全安装(H)/触发器等待(W)/触发器未决(T)
|/ 错误?=(无)/须重装(R) (状态,错误:大写=故障)
||/ 名称 版本 体系结构: 描述
+++-=============================-===================-===================-================================================================
un libssl-dev <无> <无> (无可用描述)
ii libssl-doc 1.0.1f-1ubuntu2 all Secure Sockets Layer toolkit - development documentation
ii libssl1.0.0:amd64 1.0.1f-1ubuntu2.19 amd64 Secure Sockets Layer toolkit - shared libraries

安装aptitude软件包管理器:
sudo apt-get install aptitude:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
将会安装下列额外的软件包:
aptitude-common libboost-iostreams1.54.0 libcwidget3 libept1.4.12
建议安装的软件包:
aptitude-doc-en aptitude-doc tasksel debtags libcwidget-dev
下列【新】软件包将被安装:
aptitude aptitude-common libboost-iostreams1.54.0 libcwidget3 libept1.4.12
升级了 0 个软件包,新安装了 5 个软件包,要卸载 0 个软件包,有 1 个软件包未被升级。
需要下载 2,549 kB 的软件包。
解压缩后会消耗掉 10.7 MB 的额外空间。
您希望继续执行吗? [Y/n] y
获取:1 http://cn.archive.ubuntu.com/... trusty/main libboost-iostreams1.54.0 amd64 1.54.0-4ubuntu3 [29.1 kB]
获取:2 http://cn.archive.ubuntu.com/... trusty/main libept1.4.12 amd64 1.0.12 [142 kB]
获取:3 http://cn.archive.ubuntu.com/... trusty/main aptitude-common all 0.6.8.2-1ubuntu4 [700 kB]
获取:4 http://cn.archive.ubuntu.com/... trusty/main libcwidget3 amd64 0.5.16-3.5ubuntu1 [307 kB]
获取:5 http://cn.archive.ubuntu.com/... trusty/main aptitude amd64 0.6.8.2-1ubuntu4 [1,371 kB]
下载 2,549 kB,耗时 2秒 (1,262 kB/s)
正在选中未选择的软件包 libboost-iostreams1.54.0:amd64。
(正在读取数据库 ... 系统当前共安装有 172322 个文件和目录。)
正准备解包 .../libboost-iostreams1.54.0_1.54.0-4ubuntu3_amd64.deb ...
正在解包 libboost-iostreams1.54.0:amd64 (1.54.0-4ubuntu3) ...
正在选中未选择的软件包 libept1.4.12:amd64。
正准备解包 .../libept1.4.12_1.0.12_amd64.deb ...
正在解包 libept1.4.12:amd64 (1.0.12) ...
正在选中未选择的软件包 aptitude-common。
正准备解包 .../aptitude-common_0.6.8.2-1ubuntu4_all.deb ...
正在解包 aptitude-common (0.6.8.2-1ubuntu4) ...
正在选中未选择的软件包 libcwidget3。
正准备解包 .../libcwidget3_0.5.16-3.5ubuntu1_amd64.deb ...
正在解包 libcwidget3 (0.5.16-3.5ubuntu1) ...
正在选中未选择的软件包 aptitude。
正准备解包 .../aptitude_0.6.8.2-1ubuntu4_amd64.deb ...
正在解包 aptitude (0.6.8.2-1ubuntu4) ...
正在处理用于 man-db (2.6.7.1-1ubuntu1) 的触发器 ...
正在设置 libboost-iostreams1.54.0:amd64 (1.54.0-4ubuntu3) ...
正在设置 libept1.4.12:amd64 (1.0.12) ...
正在设置 aptitude-common (0.6.8.2-1ubuntu4) ...
正在设置 libcwidget3 (0.5.16-3.5ubuntu1) ...
正在设置 aptitude (0.6.8.2-1ubuntu4) ...
update-alternatives: using /usr/bin/aptitude-curses to provide /usr/bin/aptitude (aptitude) in 自动模式
正在处理用于 libc-bin (2.19-0ubuntu6.9) 的触发器 ...

使用aptitude安装 libssl-dev包, 采用建议的解决方案(将libssl1.0.0版本降级):
sudo aptitude install libssl-dev
下列“新”软件包将被安装。
libssl-dev{b} zlib1g-dev{a}
0 个软件包被升级,新安装 2 个, 0 个将被删除, 同时 1 个将不升级。
需要获取 1,250 kB 的存档。 解包后将要使用 6,764 kB。
下列软件包存在未满足的依赖关系:
libssl-dev : 依赖: libssl1.0.0 (= 1.0.1f-1ubuntu2) 但是 1.0.1f-1ubuntu2.19 已安装。
下列动作将解决这些依赖关系:

 保持 下列软件包于其当前版本:

1) libssl-dev [未安装的]

是否接受该解决方案?[Y/n/q/?] n
下列动作将解决这些依赖关系:

 降级 下列软件包:                                                   

1) libssl1.0.0 [1.0.1f-1ubuntu2.19 (now) -> 1.0.1f-1ubuntu2 (trusty)]

是否接受该解决方案?[Y/n/q/?] Y
下列软件包将被“降级”:
libssl1.0.0
下列“新”软件包将被安装。
libssl-dev zlib1g-dev{a}
0 个软件包被升级,新安装 2 个, 1 个被降级, 0 个将被删除, 同时 1 个将不升级。
需要获取 2,075 kB 的存档。 解包后将要使用 6,747 kB。
您要继续吗?[Y/n/?] y
读取: 1 http://cn.archive.ubuntu.com/... trusty/main libssl1.0.0 amd64 1.0.1f-1ubuntu2 [825 kB]
读取: 2 http://cn.archive.ubuntu.com/... trusty/main zlib1g-dev amd64 1:1.2.8.dfsg-1ubuntu1 [183 kB]
读取: 3 http://cn.archive.ubuntu.com/... trusty/main libssl-dev amd64 1.0.1f-1ubuntu2 [1,066 kB]
已下载 2,075 kB,耗时 1秒 (1,240 kB/s)
正在预设定软件包 ...
dpkg:警告:即将把 libssl1.0.0:amd64 从 1.0.1f-1ubuntu2.19 降级到 1.0.1f-1ubuntu2
(正在读取数据库 ... 系统当前共安装有 172462 个文件和目录。)
正准备解包 .../libssl1.0.0_1.0.1f-1ubuntu2_amd64.deb ...
正在将 libssl1.0.0:amd64 (1.0.1f-1ubuntu2) 解包到 (1.0.1f-1ubuntu2.19) 上 ...
正在选中未选择的软件包 zlib1g-dev:amd64。
正准备解包 .../zlib1g-dev_1%3a1.2.8.dfsg-1ubuntu1_amd64.deb ...
正在解包 zlib1g-dev:amd64 (1:1.2.8.dfsg-1ubuntu1) ...
正在选中未选择的软件包 libssl-dev:amd64。
正准备解包 .../libssl-dev_1.0.1f-1ubuntu2_amd64.deb ...
正在解包 libssl-dev:amd64 (1.0.1f-1ubuntu2) ...
正在处理用于 man-db (2.6.7.1-1ubuntu1) 的触发器 ...
正在设置 libssl1.0.0:amd64 (1.0.1f-1ubuntu2) ...
正在设置 zlib1g-dev:amd64 (1:1.2.8.dfsg-1ubuntu1) ...
正在设置 libssl-dev:amd64 (1.0.1f-1ubuntu2) ...
正在处理用于 libc-bin (2.19-0ubuntu6.9) 的触发器 ...

验证libssl-dev包安装情况:
dpkg -l libssl
期望状态=未知(u)/安装(i)/删除(r)/清除(p)/保持(h)
| 状态=未安装(n)/已安装(i)/仅存配置(c)/仅解压缩(U)/配置失败(F)/不完全安装(H)/触发器等待(W)/触发器未决(T)
|/ 错误?=(无)/须重装(R) (状态,错误:大写=故障)
||/ 名称 版本 体系结构: 描述
+++-=============================-===================-===================-================================================================
ii libssl-dev:amd64 1.0.1f-1ubuntu2 amd64 Secure Sockets Layer toolkit - development files
ii libssl-doc 1.0.1f-1ubuntu2 all Secure Sockets Layer toolkit - development documentation
ii libssl1.0.0:amd64 1.0.1f-1ubuntu2 amd64 Secure Sockets Layer toolkit - shared libraries

然后就可以安装php5-dev插件了:
sudo apt-get install php5-dev:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
将会安装下列额外的软件包:
autoconf automake autotools-dev libltdl-dev libsigsegv2 libtool m4 shtool
建议安装的软件包:
autoconf2.13 autoconf-archive gnu-standards autoconf-doc libtool-doc
automaken gfortran fortran95-compiler gcj-jdk
推荐安装的软件包:
pkg-php-tools
下列【新】软件包将被安装:
autoconf automake autotools-dev libltdl-dev libsigsegv2 libtool m4 php5-dev
shtool
升级了 0 个软件包,新安装了 9 个软件包,要卸载 0 个软件包,有 1 个软件包未被升级。
需要下载 1,938 kB 的软件包。
解压缩后会消耗掉 10.8 MB 的额外空间。
您希望继续执行吗? [Y/n] y
。。。

注:答案是出自 http://blog.csdn.net/andy8121...,我这边做了整理

撰写回答
你尚未登录,登录后可以
  • 和开发者交流问题的细节
  • 关注并接收问题和回答的更新提醒
  • 参与内容的编辑和改进,让解决方法与时俱进
宣传栏