ubuntu安装eclipse问题

ECEPA_禧戏
  • 552

安装eclipse出现错误:
JVM terminated. Exit code=1
/usr/bin/java
-Dosgi.requiredJavaVersion=1.8
-XX:+UseG1GC
-XX:+UseStringDeduplication
-Dosgi.requiredJavaVersion=1.8
-Xms256m
-Xmx1024m
-jar /home/li/eclipse//plugins/org.eclipse.equinox.launcher_1.3.201.v20161025-1711.jar
-os linux
-ws gtk
-arch x86_64
-showsplash /home/li/eclipse//plugins/org.eclipse.platform_4.6.2.v20161124-1400/splash.bmp
-launcher /home/li/eclipse/eclipse
-name Eclipse
--launcher.library /home/li/eclipse//plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.401.v20161122-1740/eclipse_1618.so
-startup /home/li/eclipse//plugins/org.eclipse.equinox.launcher_1.3.201.v20161025-1711.jar
--launcher.appendVmargs
-exitdata 1168007
-product org.eclipse.epp.package.cpp.product
-vm /usr/bin/java
-vmargs
-Dosgi.requiredJavaVersion=1.8
-XX:+UseG1GC
-XX:+UseStringDeduplication
-Dosgi.requiredJavaVersion=1.8
-Xms256m
-Xmx1024m
-jar /home/li/eclipse//plugins/org.eclipse.equinox.launcher_1.3.201.v20161025-1711.jar

我的java -version:
java version "1.7.0_121"
OpenJDK Runtime Environment (IcedTea 2.6.8) (7u121-2.6.8-1ubuntu0.14.04.1)
OpenJDK 64-Bit Server VM (build 24.121-b00, mixed mode)
究竟什么问题?完全不懂。。。

回复
阅读 2.8k
3 个回答

需要JDK1.8重新下载jdk1.8 你的eclipse版本太高

估计是因为你用的Eclipse版本太高,Eclipse4.6版本需要JDK1.8,看你用的是OpenJDK,为啥不使用Oracle官方的JDK呢???

在Ubuntu环境下,为什么不使用idea?

撰写回答
你尚未登录,登录后可以
  • 和开发者交流问题的细节
  • 关注并接收问题和回答的更新提醒
  • 参与内容的编辑和改进,让解决方法与时俱进
宣传栏