4 个回答

我早上也报过这个错误 我建议你贴一下 webpack的配置代码

我早上解决的方案是 重新卸载了css-loader style-loader file-loader 安装用-D
然后也没有配置任何东西 之前配置的 webpack代码 css-loader!style-loader都去掉了
很意外 没有问题了

然后我刚才又试了试 加上了配置代码 中间css那块 果然 又报错了

      {
        test: /\.js$/,
        loader: 'babel-loader',
        include: [resolve('src'), resolve('test')]
      },
      {
        test:/\.css$/,
        loader:'css-loader!style-loader',
      },
      {
        test: /\.(png|jpe?g|gif|svg)(\?.*)?$/,
        loader: 'url-loader',
        options: {
          limit: 10000,
          name: utils.assetsPath('img/[name].[hash:7].[ext]')
        }
      },

clipboard.png

综上 还是不要配置了 也有可能是我自己配置错了
字体引入 你不能那么引入
应该在css中引入

 @font-face {
   font-family: DS;
   src: url("../../assets/font/DS-DIGI.TTF");
 }
 body{
   font-family: DS;
 }

现在的vue-cli里面已经配置好了css各种loader,如果再配置一遍,必须设置include属性,否则报如上错误。

夏夜丶萤火
  • 2
新手上路,请多包涵

楼上说写config里头的css-loader等报错,是因为没有加include选项

css文件解析出错了.看下是不是语法有问题

宣传栏