npm 无法更新指定模块?

npm版本: 3.10.8

...
"dependencies": {
    "webpack": "^1.14.0"
}
...
//执行命令
npm update --save webpack

//结果
(node:3392) fs: re-evaluating native module sources is not supported. If you are using the graceful-fs module, please update it to a more recent version.

版本还是没有变化?
要怎么才能够成功更新?

阅读 12.9k
评论 更新于 2017-04-13
    4 个回答
    Ter
    • 512

    以下代码会按照package.json里指定的版本升级规则升级(*,~,^,@)

    npm update webpack

    以下代码会升级到特定版本

    npm update webpack@2.3.3

    注意:此方式不会自动更新package.json文件的内容,需要手动更新

    看来大家都遇到过这种困惑,给大家推荐个npm插件npm-check,用来管理npm包版本很赞哟

    满意请推荐答案哟

    评论 赞赏 2018-04-08
      舒克
      • 1.4k

      重新安装也行,@latest 表示最新版的

      npm install webpack@latest -S
      评论 赞赏 2017-04-13

        啥意思?楼主是想更新到webpack2么- -?

        npm updata <pkg> --save 最多只能更新到当前版本的最高版。
        比如webpack1.12.0可以更新到1.14.0,但是无法更新到webpack2的
        同理jquery1.11.3最多只能更新到1.12.4无法更新到jquery3...

        评论 赞赏 2017-04-13

          你的这个webpack1已经是最新版本了!当然不能在更新了啊

          评论 赞赏 2017-04-13
            撰写回答

            登录后参与交流、获取后续更新提醒