npm安装警告

安装警告

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@^1.0.0 (node_modules\chokidar\node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.1.1: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})
阅读 2.2k
评论
    3 个回答

    其实第二个警告中的提示信息,已经给了我们答案fsevents@1.1.1: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})
    依赖fsevents想要的是操作系统是darwin,darwin是MacOSX 操作环境的操作系统成份,处理器无限制。而你的当前操作系统是32位的windows操作系统,基于x64处理器。
    简而言之,fsevent只能在MacOSX环境下使用,在windows或者linux下使用会出现警告。忽略即可。

      相似问题
      推荐文章