bower提示冲突:“ECONFLICT Unable to find suitable version for jquery”

makeup1122
  • 9

1.fork了一个cms工程,用Bower初始化前端框架时,出现如下错误

#>bower install 
....
.....
......
bower jqcron#*                                            extract archive.tar.gz
bower jqcron#*                                           resolved https://github.com/karsonzhang/jqcron.git#a3cf5dc698
bower jquery#~2.1.4                                        cached https://github.com/jquery/jquery-dist.git#2.1.4
bower jquery#~2.1.4                                      validate 2.1.4 against https://github.com/jquery/jquery-dist.git#~2.1.4
bower jquery#>= 1.8.3                                      cached https://github.com/jquery/jquery-dist.git#3.2.1
bower jquery#>= 1.8.3                                    validate 3.2.1 against https://github.com/jquery/jquery-dist.git#>= 1.8.3
bower bootstrap#>= 3.1.0                                   cached https://github.com/twbs/bootstrap.git#3.3.7
bower bootstrap#>= 3.1.0                                 validate 3.3.7 against https://github.com/twbs/bootstrap.git#>= 3.1.0
bower jquery#>=1.2                                         cached https://github.com/jquery/jquery-dist.git#3.2.1
bower jquery#>=1.2                                       validate 3.2.1 against https://github.com/jquery/jquery-dist.git#>=1.2
bower html2canvas#*                                        cached https://github.com/niklasvh/html2canvas.git#0.4.1
bower html2canvas#*                                      validate 0.4.1 against https://github.com/niklasvh/html2canvas.git#*
bower file-saver#>=1.2.0                                   cached https://github.com/eligrey/FileSaver.js.git#1.3.3
bower file-saver#>=1.2.0                                 validate 1.3.3 against https://github.com/eligrey/FileSaver.js.git#>=1.2.0
bower jspdf-autotable#2.0.14 || 2.0.17                     cached https://github.com/someatoms/jsPDF-AutoTable.git#2.0.17
bower jspdf-autotable#2.0.14 || 2.0.17                   validate 2.0.17 against https://github.com/someatoms/jsPDF-AutoTable.git#2.0.14 || 2.0.17
bower jspdf#1.1.239 || 1.3.2                               cached https://github.com/MrRio/jsPDF.git#1.3.2
bower jspdf#1.1.239 || 1.3.2                             validate 1.3.2 against https://github.com/MrRio/jsPDF.git#1.1.239 || 1.3.2
bower jspdf#~1.0.178                                       cached https://github.com/MrRio/jsPDF.git#1.0.272
bower jspdf#~1.0.178                                     validate 1.0.272 against https://github.com/MrRio/jsPDF.git#~1.0.178
bower                                                   ECONFLICT Unable to find suitable version for jquery
#>

本人是写后端的,对前端这bower不太了解,清除了bower缓存,重新install也还是一样的错误。
发现install有个-F参数,虽然可以安装成功,但会被提示代码可能有兼容性问,不知是否有影响?
我记得bower遇到冲突应该是可以手动选择版本的呀?为何我这里就直接结束了,不给一点机会-,-。
我的环境是

  • win10 + git bash

  • bower -v = 1.8.0

  • node -v = 7.9.0

评论
阅读 2.4k
撰写回答

登录后参与交流、获取后续更新提醒

宣传栏