0

.babelrc

{
  "presets": [
    ["es2015", { "modules": false }],
    ["es2016"],
    "stage-2"
  ],
  "plugins": ["transform-runtime"],
  "comments": false,
  "env": {
    "test": {
      "plugins": [ "istanbul" ]
    }
  }
}

我在 .babelrc 里使用了 babel-plugin-transform-runtime,还需要引入 es6-promise 吗?

查看全部 2 个回答

0

一篇关于Polyfill 方案方案的,https://zhuanlan.zhihu.com/p/...

推荐答案

1

谢邀,不需要的,transform runtime 可以避免 babel promise 污染全局,会自动把

var promise = new Promise()

转换为

var _promise = require("babel-runtime/core-js/promise");
var _promise2 = _interopRequireDefault(_promise);

var promise = new _promise2.default();