我用weexpack构建weex应用时,npm run serve一直报这个错误

施奇
  • 51
ERROR in index.web.js from UglifyJs
Unexpected token: name (urlParts) [index.web.js:3689,4]
Child html-webpack-plugin for "index.html":
    chunk    {0} index.html 963 bytes [entry]
         + 1 hidden modules
webpack: Failed to compile.
webpack: Compiling...
Hash: 024e2158e2ef9c332c25
Version: webpack 2.7.0
Time: 157ms
           Asset    Size  Chunks                    Chunk Names
    index.web.js  341 kB       0  [emitted]  [big]  index
index.web.js.map  406 kB       0  [emitted]         index
chunk    {0} index.web.js, index.web.js.map (index) 326 kB [entry]
   [36] ./temp?entry=true 87 bytes {0} [built]
   [94] ./~/webpack/hot nonrecursive ^\.\/log$ 160 bytes {0} [built]
     + 94 hidden modules
回复
阅读 3.3k
8 个回答

你可以更新一下weex-toolkit重新创建应用,现在最新的版本是1.0.8-beta2,这个应该是之前版本修改带来的问题
直接weex update weexpack然后创建项目试试,再不行的话直接重装weex-toolkit,npm i weex-toolkit@latest -g

全局搜索 new webpack.optimize.UglifyJsPlugin({minimize: true}),

注释掉这一行就好了。

// web need vue-loader
const plugins = [
    // new webpack.optimize.UglifyJsPlugin({minimize: true}), //这行不要
    new webpack.BannerPlugin({
        banner: '// { "framework": ' + (fileType === '.vue' ? '"Vue"' : '"Weex"') + '} \n',
        raw: true,
        exclude: 'Vue'
    })
];

cnpm 安装的UglifyJs包有问题,用npm i安装即可。

米洛诗
  • 2
新手上路,请多包涵

你应该更新UglifyJs,用npm i -D uglify-js@1.0.0-beta.2, 然后在webpack.config.jsconst UglifyJSPlugin = require('uglifyjs-webpack-plugin')

const plugins = [
  new UglifyJSPlugin({minimize: true}),
  ...

这个问题,我是直接用npm安装规避的,用cnpm安装的依赖包确实会出现问题。

你知道吗?

宣传栏