vue-cli 用 npm run build 时出现这个错误

Wgrape
  • 224

错误如图 :

图片描述

(图片有点小,请查看原图)

别人说是 uglifyjs-webpack-plugin 版本问题,换成 1.1.3 就行了,
可是我换成 1.1.3 还是不行 ( 原始版本是 1.1.1 )。。。

求助 ,非常感谢 !!!!!

----------------2017年12月26日更新-----------------------

谢谢大家的回答,问题我现在已经解决了,问题就在于我当时使用 npm ( 墙 ) 导致下载的模块不完整,我以为我当时设置的就是淘宝镜像,就一直没在意,后来才发现我当时使用 npm config set registry http://registry.npm.taobao.org/ 这个命令只能改变临时的下载源,后来我在npm的配置文件 npmrc 中直接设置了registry = https://registry.npm.taobao.org 就行了 。

回复
阅读 4k
6 个回答
✓ 已被采纳

谢谢大家的回答,问题我现在已经解决了,问题就在于我当时使用 npm ( 墙 ) 导致下载的模块不完整,我以为我当时设置的就是淘宝镜像,就一直没在意,后来才发现我当时使用 npm config set registry http://registry.npm.taobao.org/ 这个命令只能改变临时的下载源,后来我在npm的配置文件 npmrc 中直接设置了registry = https://registry.npm.taobao.org 就行了 。

谢邀!
您看一下README.md有没有关于 uglifyjs-webpack-plugin 的注释?比如我这边 README.md文 文件开头的一段话!

webpack =< v3.0.0 currently contains v0.4.6 of this plugin under `webpack.optimize.UglifyJsPlugin as an alias. For usage of the latest version (v1.0.0), please follow the instructions below. Aliasing v1.0.0 as webpack.optimize.UglifyJsPlugin is scheduled for webpack v4.0.0

于是乎我将 package.json 中的 uglifyjs-webpack-plugin 的版本手动改为 ^0.4.6 ,再重新 npm install
如果改完之后还不行,那有可能是npm缓存的问题:

将整个 node_modules 目录全部删除,再次运行 npm install 试试

xdsnet
  • 7.5k

你是按那个教程开始的,是否是相关的依赖安装不完整?或者构建项目进行初始化后没有执行依赖初始化。
比如执行过 npm install没有?

有没有删除全部的包,然后重新npm install一遍?

伽蓝夜雨丶
  • 187

将整个 node_modules 目录全部删除,重新运行 npm install 试试

html-minifier 版本是否为 3.5.8 ,改为低版本,我是这么解决的.

宣传栏