vue-cli项目npm run build为什么出错?

Decade
  • 47

最常规的vuecli项目初始化

vue init webpack vue-mysql
cd vue-mysql
npm run dev

这些操作没问题
然后我就进行了npm run build
这个时候我还没有添加我的任何代码,居然出现了报错

clipboard.png
然后我就去根据报错找原因
根据这篇https://segmentfault.com/q/10...
进行了尝试,然并卵
之前项目从未出现这种情况,找了很久都没发现错误,求大神解答

回复
阅读 3.5k
4 个回答

看代码是uglifyjs-webpack-plugin这个webpack插件里面有句代码有问题,翻了下issues也有人遇到同样的问题,将版本改低就好了。

我也碰到了同样的问题,但是上周五还是好好的。于是我对比了之前的 package.json,发现 uglifyjs-webpack-plugin 的版本是 0.4.6,但现在已经是1.1.4了。解决方案:将package.json中的uglifyjs-webpack-plugin的版本手动改为^0.4.6,再重新npm install

上面不是说了吗 typeError里说那里没有这个方法

你这node和npm版本有点低呀,可能是版本太低了

应该是版本问题

宣传栏