angular5在IDEA中无法自动import

empty_
  • 2
新手上路,请多包涵

图片描述

ALT+ENTER自动引入包会出现这些,但我只需要@angular/core,自从把angular更新到最新版之后就变成了这样,并且会编译失败。
package.json和node_modules文件夹里的package-version文件里的格式都是正常的。

图片描述

图片描述

编译报错内容
图片描述
图片描述

回复
阅读 2.6k
3 个回答

楼上截图中的导入之后,会出现错误。是因为导入的是 core/src/core 把源码导入了。
似乎是typescript的bug。有些版本会有这个问题。

图片描述

这不就是吗

chengcheng
  • 3
新手上路,请多包涵

不是应该用webstorm吗?我用的webstorm没什么问题。你试试升级到最新版的ide吧。angular5才出来没多久,ide换个最新版的好一点。

你知道吗?

宣传栏