Babel 使用了babel-preset-env,不再需要`import 'babel-polyfill'`吗?

cjwj
  • 628

import 'babel-polyfill'

看 vue-cli 生成的项目 Babel 配置,main.js中已经没有import 'babel-polyfill'了,是因为
使用了babel-preset-env吗?

{
  "presets": [
    ["env", {
      "modules": false
    }],
    "stage-2"
  ],
  "plugins": ["transform-runtime"],
  "env": {
    "test": {
      "presets": ["env", "stage-2"],
      "plugins": ["transform-es2015-modules-commonjs", "dynamic-import-node"]
    }
  }
}
回复
阅读 3.6k
2 个回答
大桔子
  • 552
  • 看一下这位大佬的回答
  • https://zhuanlan.zhihu.com/p/...
  • https://segmentfault.com/a/11...
  • babel-presets-env 根据 env的 targets的配置(需要声明 useBuiltIns) 按需引入你需要的 polyfill
  • 使用 transform-runtime 方式引入polyfill,一般开发第三方库需要这样引入(这种引入不会改变全局对象,不会改变原型属性、方法,体积较小)

这是我的 babelrc 配置

{
  "presets": [
    [
      "env",
      {
        "modules": false,
        "useBuiltIns": 'usage',
        "targets": {"browsers": ["last 2 versions", "safari >= 7", "ie>=9"]}
      }
    ],
    "stage-0",
    "react"
  ],
  "plugins": ["syntax-dynamic-import"]
}
"plugins": ["transform-runtime"],
撰写回答
你尚未登录,登录后可以
  • 和开发者交流问题的细节
  • 关注并接收问题和回答的更新提醒
  • 参与内容的编辑和改进,让解决方法与时俱进
宣传栏