引入vux,v-chart 报错

梦婷
  • 207

引入vux,v-chart 报错,错误信息如下:

ERROR Failed to compile with 1 errors 18:17:42

error in ./node_modules/_vux@2.9.1@vux/src/components/v-chart/mixin.js

Module parse failed: Unexpected token (18:6)
You may need an appropriate loader to handle this file type.
| this.$parent.set(this.chartName, {
| shape: defaultShapeMap[this.chartName] || '',
| ...this.$props,
| ...camelAttrs(this.$attrs)
| })
回复
阅读 8.1k
4 个回答
✓ 已被采纳

谢邀!
vux2必须配合vux-loader使用, 请在build/webpack.base.conf.js里参照如下代码进行配置:

const vuxLoader = require('vux-loader')
const webpackConfig = originalConfig // 原来的 module.exports 代码赋值给变量 webpackConfig

module.exports = vuxLoader.merge(webpackConfig, {
  plugins: ['vux-ui']
})

具体参考:安装使用(webpack)

zhaolei
  • 3
新手上路,请多包涵

朋友 你解决了吗 我也出现这个问题了 想请教你一下

这个错误是因为对象运算符没有被解析,需要安装对应插件来解析对应语法,transform-object-rest-spread,还得在.babelrc文件里面配置一下

Esther
  • 1
新手上路,请多包涵

怎么解决的,我按文档写了,一直报这个错

你知道吗?

宣传栏