sockjs-client的使用问题

在使用sockjs-client的时候遇到下面提示的问题,使用的版本是1.1.5, 看网上的回答很多说降到1.0.0的版本,还是有问题, 这个是什么引起的呢?

Uncaught Error: Incompatibile SockJS! Main site uses: "1.1.5", the iframe: "1.0.0".

回复
阅读 6.9k
1 个回答

前段静态引入是没问题的

<script src="https://cdn.jsdelivr.net/npm/sockjs-client@1/dist/sockjs.min.js"></script>
    var sock = new SockJS('https://mydomain.com/my_prefix');
     sock.onopen = function() {
         console.log('open');
         sock.send('test');
     };

撰写回答
你尚未登录,登录后可以
  • 和开发者交流问题的细节
  • 关注并接收问题和回答的更新提醒
  • 参与内容的编辑和改进,让解决方法与时俱进
推荐问题
宣传栏