共被编辑 4 次

版本 更新时间 贡献者 编辑原因 操作
#r4 2018年12月07日 烧麦179 更新问题 查看

vagrant可以正常启动 但是浏览器不能访问项目

vagrant已经安装使用了很久了,已经在虚拟机安装了LNMP环境,也是可以使用的,可是今天出现一个奇怪现象:我vagrant up正常启动后,去浏览器访问突然不能访问了,ssh进去发现环境也都是正常的,在虚拟机curl 192.168.1.105可以正常访问的,在win的cmd去ping 192.168.1.105也是通的。
vagrantFile的ip设置是:config.vm.network "public_network",ip: "192.168.1.105"
win下的cmd ipconfig结果如下:
图片描述

虚拟机的ifconfig结果如下:
图片描述

启动页面如图:
图片描述
我也不知道为什么会这样,之前一直好好的,请各位帮帮忙,谢谢, 而且发现一个现象,去重启电脑之后,vagrant up后又可以正常访问,一旦vagrant关闭或vagrant重启就不能访问

#r3 2018年12月06日 烧麦179 更新问题 查看

vagrant可以正常启动 但是不能访问项目

vagrant已经安装使用了很久了,已经在虚拟机安装了LNMP环境,也是可以使用的,可是今天出现一个奇怪现象:我vagrant up正常启动后,去浏览器访问突然不能访问了,ssh进去发现环境也都是正常的,在虚拟机curl 192.168.1.105可以正常访问的,在win的cmd去ping 192.168.1.105也是通的。
vagrantFile的ip设置是:config.vm.network "public_network",ip: "192.168.1.105"
win下的cmd ipconfig结果如下:
图片描述

虚拟机的ifconfig结果如下:
图片描述

启动页面如图:
图片描述
我也不知道为什么会这样,之前一直好好的,请各位帮帮忙,谢谢, 而且发现一个现象,去重启电脑之后,vagrant up后又可以正常访问,一旦vagrant关闭或vagrant重启就不能访问

#r2 2018年12月06日 烧麦179 更新问题 查看

vagrant可以正常启动 但是不能访问项目

vagrant已经安装使用了很久了,已经在虚拟机安装了LNMP环境,也是可以使用的,可是今天出现一个奇怪现象:我vagrant up正常启动后,去浏览器访问突然不能访问了,ssh进去发现环境也都是正常的,在虚拟机curl 192.168.1.105可以正常访问的,在win的cmd去ping 192.168.1.105也是通的。
vagrantFile的ip设置是:config.vm.network "public_network",ip: "192.168.1.105"
win下的cmd ipconfig结果如下:
图片描述

虚拟机的ifconfig结果如下:
图片描述

启动页面如图:
图片描述
我也不知道为什么会这样,之前一直好好的,请各位帮帮忙,谢谢

#r1 2018年12月06日 烧麦179 创建问题 查看

vagrant可以正常启动 但是不能访问项目

vagrant已经安装使用了很久了,已经在虚拟机安装了LNMP环境,也是可以使用的,可是今天出现一个奇怪现象:我vagrant up正常启动后,去浏览器访问突然不能访问了,ssh进去发现环境也都是正常的,在虚拟机curl 192.168.1.105可以正常访问的,在win的cmd去ping 192.168.1.105也是通的。
vagrantFile的ip设置是:config.vm.network "public_network",ip: "192.168.1.105"
win下的cmd ipconfig结果如下:
图片描述

虚拟机的ifconfig结果如下:
图片描述

我也不知道为什么会这样,之前一直好好的,请各位帮帮忙,谢谢