0

问题描述

IntelliJ IDEA 中建立 Gradle 项目,gradle/wrapper/gradle-wrapper.properties 文件中指定的 gradle 版本一直是 4.10.2,我本地 gradle 已经更新到 5.2.1 了,请问如何指定最新的版本呢?

gradle/wrapper/gradle-wrapper.properties

distributionBase=GRADLE_USER_HOME
distributionPath=wrapper/dists
distributionUrl=https\://services.gradle.org/distributions/gradle-4.10-bin.zip
zipStoreBase=GRADLE_USER_HOME
zipStorePath=wrapper/dists

问题出现的环境背景及自己尝试过哪些方法

macOS Mojave,Gradle 5.2.1,IntelliJ IDEA 2018.3.3 Ultimate Edition

自己尝试过可以通过下面命令手动更新 gradle-wrapper 版本

./gradlew wrapper --gradle-version 5.2.1

你期待的结果是什么?实际看到的错误信息又是什么?

请问如何在创建项目时指定 gradle-wrapper 版本呢?在哪里设置默认的版本呢?我不想等项目创建完成后再手动指定新版本

2019-02-15 提问
1 个回答
0

目前 IDEA 使用的版本是 IDEA 绑定的 Gradle 插件决定的,这个问题已经在 IntelliJ's issue tracker 中提出来了,持续关注。

https://youtrack.jetbrains.co...

答案来自我在 Stack Overflow 上的问题

https://stackoverflow.com/que...

撰写答案

推广链接