0

问题描述

安装并运行pyspider一路艰辛,为啥会这么艰难呢,要么就是python版本不兼容,要么就是openssl版本不对,好不容易解决一个报错又来一个报错,这次的报错内容是:

ValueError: Invalid configuration:

  • Deprecated option 'domaincontroller': use 'http_authenticator.domain_controller' instead.

问题出现的平台版本及自己尝试过哪些方法

Python版本是3.7.1
mac版本是10.12.6
Pycurl版本是7.43.0.2
OpenSSl版本是1.0.2r 26 Feb 2019

尝试过降低wsgidav版本,执行代码如下:#该代码会报错,提示没有对应匹配的低版本

python -m pip install wsgidav==2.4.1

转自https://blog.csdn.net/SiHann/...

尝试过修改webdav.py的代码:#修改了还是没效果

在安装包中找到pyspider的资源包,然后找到webui文件里面的webdav.py文件打开,修改第209行即可,

'domaincontroller': NeedAuthController(app),

修改为:

'http_authenticator':{'HTTPAuthenticator':NeedAuthController(app),},

转自https://blog.csdn.net/qq_3725...

相关代码

// 请把代码文本粘贴到下方(请勿用图片代替代码)
具体报错代码行:

ValueError: Invalid configuration:

  • Deprecated option 'domaincontroller': use 'http_authenticator.domain_controller' instead.

你期待的结果是什么?实际看到的错误信息又是什么?

这个问题解决应该就能在浏览器执行localhost:5000了,求大能解决该问题?

2019-04-26 提问
1 个回答
1

我把命令修改了一下,就不报错了,可以在安装wsgidav2.4.1的同时卸载3.0.0版本
pip install wsgidav==2.4.1
大家可以试一试,很不错

撰写答案

推广链接