0

[通过最新vue-ci 启动的项目]

全局安装 vue-cli

$ npm install --global vue-cli

创建一个基于 mpvue-quickstart 模板的新项目

$ vue init mpvue/mpvue-quickstart my-project

安装依赖

$ cd my-project
$ npm install

启动构建

$ npm run dev
问题复现步骤:

按上执行
"dependencies": {
"@antv/f2-canvas": "~1.0.5",
"@antv/wx-f2": "~1.1.4",
"mpvue": "^2.0.0",
"vuex": "^3.0.1"
}, 更改package.json文件
然后点击小程序开发者工具,构建Npm,已勾选使用Npm模块
观察到的表现:

没有找到可以构建的 NPM 包。

2019-05-16 提问
1 个回答
0

你应该把错误的截图贴上来。

1、我的建议是直接把你需要的npm包的源码直接拿出来,放到你的源码中,这样可以减少好多麻烦。

2、请检查一下你需要的npm包里面是不是直接使用了node的内置 API做的一层封装,因为小程序的 NPM 包构建是没有办法提取node的内置 API的,这个时候就会构建失败,找不到 NPM 包

3、小程序的 NPM 包 一般建议是使用能在纯粹 JavaScript 环境下能正常运行的,毕竟小程序的运行环境没有 node

撰写答案

推广链接