0

问题描述

wordpress的机房快到期了,不准备续期打算搬家到hexo算了
我按照hexo官网文档建hexo博客
hexo博客都已经搭建好了
在要进行文章迁移时发现报这样的错?
搜了全网也没发现相同的问题

npm WARN deprecated left-pad@1.3.0: use String.prototype.padStart()
npm ERR! Unexpected end of JSON input while parsing near '...0.4.28":{"name":"ws",'

npm ERR! A complete log of this run can be found in:
npm ERR!     C:\Users\jokrface\AppData\Roaming\npm-cache\_logs\2019-06-12T23_42_50_103Z-debug.log

报错截图
图片描述

问题出现的平台版本及自己尝试过哪些方法

按照这个提问中的参考解决办法
https://segmentfault.com/q/10...
使用npm install https://github.com/hexojs/hexo-migrator-wordpress.git --save也是一样的报错提示

相关代码

// 请把代码文本粘贴到下方(请勿用图片代替代码)

npm install hexo-migrator-wordpress --save
npm install https://github.com/hexojs/hexo-migrator-wordpress.git --save

你期待的结果是什么?实际看到的错误信息又是什么?

2019-06-13 提问
1 个回答
0

问题终于解决了,感谢S1的巨佬,感觉还是网络的问题偏多一些
这里没人解答,我还是贴一下吧
先改成淘宝源npm config set registry https://registry.npm.taobao.org
再安装一遍npm install hexo-migrator-wordpress --save
然后会提示要安装eslint
于是安装eslintnpm install eslint --save
这时会提示要安装acorn
继续安装acornnpm install acorn --save
这个时候再重新安装一次migrator

npm install hexo-migrator-wordpress --save

会提示audit fix
fix一下npm audit fix

然后就可以开始迁移wordpress文章了

撰写答案

推广链接