composer install太慢如何解决?

我使用composer安装和更新的时候都是卡在

Loading composer repositories with package information
Updating dependencies (including require-dev)

一直卡在这里就不动了,不知道是什么原因,找了许多中国镜像,切换后还是同样的问题。

等待许久后会有这样的报错

 [Composer\Downloader\TransportException]                                  
  Content-Length mismatch,

请问大家有遇到这样的问题么?如何解决?

阅读 3k
评论
    3 个回答

    换个其他源,以下任选其一

    #阿里云的composer镜像源
    composer config -g repo.packagist composer https://mirrors.aliyun.com/composer/
    #腾讯云的composer镜像源
    composer config -g repo.packagist composer https://mirrors.cloud.tencent.com/composer/

    然后执行composer的时候加-vvv查看哪一步卡住了。

      增加swap 交换空间

        • 1
        • 新人请关照

        问题: 在Yii2中安装一些插件时,现在Yii2默认的jQuery版本是v3版本,但很多插件不支持v3版本仅支持v2版本。

        于是,修改composer.json => "bower-asset/jquery": "~2.1.1",
        但,更新特别慢,几乎是卡住了(使用的是阿里云composer源)

        可以尝试以下解决方法:
        composer global require "fxp/composer-asset-plugin:^1.4.1" --no-plugins

        然后
        composer -vvv update 更新完成,速度也可以。

          撰写回答

          登录后参与交流、获取后续更新提醒