bleachin
  • 3
  • 新人请关照

php 5.3.29 nts版,安装swoole 1.9.1扩展,报“core_globals_id”错误

具体错误:PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/swoole.so' - /usr/lib64/php/modules/swoole.so: undefined symbol: core_globals_id in Unknown on line 0。

https://phperzh.com/articles/...

clipboard.png

我的php是nts版的。

clipboard.png

阅读 267
评论 更新于 2019-09-09
    1 个回答
    bleachin
    • 3
    • 新人请关照

    我自己来回答吧,swoole只支持php ts线程安全版的,需要重新编译php,配置编译时加入--enable-maintainer-zts。

    评论 赞赏 2019-09-09