0

我创建项目的步骤如下,我真的为此烦恼了一天了.

第一步选择骨架
1.png
关联自己的maven路径和配置
2.png
构建出来的项目如下:
4.png

这个项目出来的问题有以下问题:

  • 首先是Maven工具栏没有没有Dependencies和Plugins.
  • 其次,创建出来的项目没有Artifacts和Facets信息.
  • 还有,我点击刷新,

5.png

我使用的idea是2019.2.2 ,maven是3.5.4

我快要被这个折磨死了!求救### 问题描述

11月6日提问
3 个回答
0

已采纳

原因我找到了,idea2019.2.2的版本和maven3.6.2的版本不兼容,这垃圾maven3.6.2,折磨了我2天
把maven换低版本的,就没问题了,一切都正常。
希望能帮到和我一样遇到这种天坑的小伙伴!

0

编译一下?
mvn clean package
或者
mvn clean install

0

plugins对应的是pom.xml的里plugins的配置段。
看看你的pom.xml里有没有,
如果完成没有,加一下试试

<plugins>
             <plugin>
                <artifactId>maven-compiler-plugin</artifactId>
                <version>3.2</version>
                <configuration>
                    <source>1.8</source>
                    <target>1.8</target>
                    <encoding>UTF-8</encoding>
                    <useIncrementalCompilation>true</useIncrementalCompilation>
                </configuration>
            </plugin>
</plugins>

撰写答案

推广链接