antD npm start 报错

拾光过客
  • 605

删除node_modules,重新 npm install 或 cnpm install,同样结果.这个Umi好像出问题,如何解决呢

Plugin apply failed: Cannot find module '/home/XXX/下载/intelligenttransfront/src/pages/user/register-result'
/home/XXX/下载/intelligenttransfront/node_modules/_umi-build-dev@1.16.12@umi-build-dev/lib/Service.js:308
        throw e;
        ^

Error: Cannot find module '/home/XXX/下载/intelligenttransfront/src/pages/user/register-result'
    at Function.Module._resolveFilename (internal/modules/cjs/loader.js:636:15)

Screenshot from 2020-01-09 09-26-26.png

回复
阅读 3.2k
4 个回答

你应该问的是npm install报错吧,你先把node_modules删了,然后把package-lock.json删了,然后清缓存:

npm cache clear --force

最后npm install试试

给的信息较少,根据上面的信息我提供两种方法,仅供参考:
1、若是umi出问题了,先把node_modules目录删除,把缓存npm cache clear --force清一下,然后先单独安装npm install umi --save,然后再执行npm install
2、尝试升级或者降低node版本试一下,node升降时npm版本会随之自动改变,推荐使用管理工具nvm及其相关工具gnvm之类的,可以同时安装多个node版本,想用哪个就切换到哪个就好,这个网上方法很多

还可以尝试锁定 umi 版本

信息比较少,如果在vscode中执行命令报错的话,可以试试在外部另开命令行窗口,然后执行所需命令

宣传栏