angular7使用ng2-pdf-viewer可以运行但是页面报错

如图,angular7需要pdf预览,选择npm  ng2-pdf-viewer ,可以运行,但是页面报了如图这个错误。

(Promise.allSettled is not a function
    at MessageHandler._deleteStreamController)

在GitHub看到有人说是要将zone升级到0.10以上版本,然而我们公司这个项目的版本不能动,因此想问下除了升级版本还有其他解决方法么?

阅读 166
评论
    1 个回答
      撰写回答

      登录后参与交流、获取后续更新提醒