webpack3 升级webpack4后,打包报错

ERROR in Encountered an error while minifying static/js/239.a78507da56f201d78a6e1606289989328.js:

SyntaxError: Unexpected token: punc ())

ERROR in Encountered an error while minifying static/js/298.224ce6bad851545d8ed51606289989328.js:

SyntaxError: Unexpected token: keyword (const)

有很多这样的错,是ES6转化的问题吗

{
    "presets": [
        ["@babel/env", { // babel7的写法,
         "targets": {
                        "edge": "17",
         "firefox": "60",
         "chrome": "67",
         "safari": "11.1"
         },
         "corejs": "2", // 指定编译的corejs版本,否则构建线上环境时会报警告
         "useBuiltIns": "usage"
         }]
            ],
         "plugins": ["transform-vue-jsx", "@babel/plugin-transform-runtime", "@babel/plugin-syntax-dynamic-import"]
        }
阅读 83
评论
    0 个回答
    撰写回答

    登录后参与交流、获取后续更新提醒

    相似问题
    推荐文章