Angular版本升级出现问题了

葬天尘
  • 266

概述

我的Angular项目当时创建时是 Angular8.2 ,现在这个项目要继续开发,发现 Angular 已经升级10了,今天升级这个项目出现问题了,我的做法是这样的。

我的升级步骤

  1. 执行 ng update @angular/core@8 @angular/cli@8 升级到8版本的最新状态
  2. git add . 然后 commit 提交
  3. 执行 ng update @angular/core@9 @angular/cli@9 升级到9,到这一步出现了兼容问题

image

我的努力

我的项目中适用了 PrimeNG 和 zorro-antd-design 的两套组件,看上图很明显的给出了是 PrimeNG 不兼容 zone.js ,意思是我要先升级 PrimeNG ?

回复
阅读 1.7k
1 个回答

Angular9.0开始默认启用新的IVY编译方式,如果PrimeNG版本过低的化确实会出现兼容性问题,可以尝试升级
升级注意事项可以在这里查看: https://update.angular.io/?v=...

撰写回答
你尚未登录,登录后可以
  • 和开发者交流问题的细节
  • 关注并接收问题和回答的更新提醒
  • 参与内容的编辑和改进,让解决方法与时俱进
宣传栏