按需引入 antd 一用组件就报错 Possibly missing '(' in mixin call

image.png
image.png
node_modules 下的 antd 文件夹下的 .less文件的 mixin用法都加上括号就不报错了,但是我要每引入一个就加括号,这不太合理呀,我之前弄得也没有这个情况。
项目有 lesssass 两个预处理语言,我每引入一个组件就报几个错,这该怎么解决呀?

// less 版本
    "less": "^4.0.0",
    "less-loader": "7.2.1",

//// main.ts
import './styles/antdTheme.js'

// antdTheme.js
import Vue from "vue";
import {Button, message} from 'ant-design-vue'

[Button, message].forEach((item) => {
  Vue.use(item);
});

Vue.prototype.$message = message


// babel.config.js
module.exports = {
  presets: ["vca-jsx", "@vue/cli-plugin-babel/preset"],
  plugins: [
    [
      "import",
      { libraryName: "ant-design-vue", libraryDirectory: "es", style: true }
    ]
  ]
};

// vue.config.js
const modifyVars = require("./src/styles/antdTheme.js");

 css: {
    loaderOptions: {
      sass: {
        prependData: `
        @import '@/styles/variable.scss';
        @import '@/styles/mixins.scss';
        @import '@/styles/global.scss';
        `
      },
      less: {
        lessOptions: {
          javascriptEnabled: true,
          modifyVars
        }
      }
    }
  }
阅读 424
评论
    2 个回答
    1. less 版本降到 3.0 以下,less-loader 降到 5.0.0

      1. npm i --save-dev less@2.7.3 less-loader@5.0.0
      2. less3.0版本会报下面这个错,less4.0会报上面的错Possibly missing '(' in mixin call

        sadasd.png

      • 1
      • 新人请关照

      应该是less的版本有问题,可以吧less的版本后退一下,后退到3.x版本

        撰写回答

        登录后参与交流、获取后续更新提醒

        相似问题
        推荐文章