mysql启动报错缺失libssl.1.0.0.dylib,如何解决?

Eichner
  • 47

问题描述

很久没有碰后端了,最近要用到数据库,然后mysql指令下出现报错 Library not loaded: /usr/local/opt/openssl/lib/libssl.1.0.0.dylib,我搜了一下,有很多人说到是python3导致openssl的版本升级了,使用brew switch openssl1.0.2r就可以正常使用了,但问题是我没有openssl1.0.2r,切换不过去。

问题出现的平台版本及自己尝试过哪些方法

macOS:Big Sur11.1
Homebrew: 2.7.6
openssl: 1.1.1d
我看到自己已有的版本只有这一个 /usr/local/Cellar/openssl@1.1/1.1.1d

请问如何解决这个报错,非常感谢!

回复
阅读 263
2 个回答

要不,自己编译安装一个1.0版本的 openssl
或者,你安装一个新版本的 mysql .

你这应该用的是homebrew装的mysql吧?再用brew重装一次mysql就行了

撰写回答
你尚未登录,登录后可以
  • 和开发者交流问题的细节
  • 关注并接收问题和回答的更新提醒
  • 参与内容的编辑和改进,让解决方法与时俱进
你知道吗?

宣传栏