vue项目安装插件时,报了@babel/core以及@babel/preset-es2015的错误,请教该怎么解决?

amilytom
  • 658

image
image

试过将@babel/core和@babel/preset-es2015删除,然后再重新下载,结果删除的时候也报错,报错同上面的情形差不多。

这个项目时从github上下载,springboot+vue
https://github.com/YXJ2018/Sp...
springboot已经成功实施,目前vue部署之后开始npm install安装插件,出现的问题。
请教万能的大佬,遇到这样的问题该怎么解决?

回复
阅读 151
1 个回答

npm 安装的都是最新的包,用yarn装试试,这个项目可能比较老,新包的兼容性不好。

先把node_module删了

npm i yarn -g

...

yarn install 或者 npx yarn install
撰写回答
你尚未登录,登录后可以
  • 和开发者交流问题的细节
  • 关注并接收问题和回答的更新提醒
  • 参与内容的编辑和改进,让解决方法与时俱进
你知道吗?

宣传栏